[kuangbin带你飞]专题五 并查集 A - Wireless Network

A - Wireless Network

 

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
int pre[1005],dis[1005][1005],l[1005],r[1005],vis[1005],n,m;
int juli(int a1,int b1,int a2,int b2)
{
    int a=a1-a2,b=b1-b2;
    return a*a+b*b;
}
int find(int x) //路径压缩
{
    if(x!=pre[x]) pre[x]=find(pre[x]);
    return pre[x];
}
void join(int x,int y) //合并集合
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy) pre[fx]=fy;
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++) //输入电脑坐标和初始化
    {
        vis[i]=0;
        pre[i]=i;
        scanf("%d%d",&l[i],&r[i]);
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            dis[i][j]=juli(l[i],r[i],l[j],r[j]); //初始化每个电脑之间的距离
        }
    }
    char c[5];
    while(scanf("%s",c)!=EOF)
    {
        if(c[0]=='O')
        {
            int x;
            scanf("%d",&x);
            vis[x]=1;
            for(int i=1;i<=n;i++)
            {
                if(vis[i]&&dis[x][i]<=m*m) //只要电脑被修好且可以直接走到,就合并
                    join(x,i);             //重点是用乘不用sqrt
            }
        }
        else
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(find(x)==find(y)) printf("SUCCESS\n"); //要是都是一样的爸爸,就success
            else printf("FAIL\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/81039710