[kuangbin带你飞]专题五 并查集 D - How Many Answers Are Wrong(带权并查集)

D - How Many Answers Are Wrong

题目链接:https://vjudge.net/contest/66964#problem/D

题目:

TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

InputLine 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.
OutputA single line with a integer denotes how many answers are wrong.Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1
Sample Output
1
题意:这题我刚开始看感觉跟并查集没什么关系,没懂啥意思,后来看了看,题目是说:有n个数给你m组数,每组的a,b,c代表从第a个数到第b个数的和为c,看看有多少矛盾的,求矛盾的组数

思路:要把a-1,这样就行了前闭后开的区间,可以处理a和b相等的情况,然后开一个数组记录左端点的权值也就是到根节点的权值和。先判断左端点和右端点的“爸爸”是否相同,
相同的话拿左端点到根节点的权值和和右端点到根节点的权值和之差是否为c即可,不是则矛盾。如果“爸爸”不同,那么就更新端点的权值,左端点“爸爸”的权值更新为右端点的权值-左端点的权值+c。

//
// Created by hanyu on 2019/7/24.
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <set>
using namespace std;
const int maxn=200005;
int father[maxn],value[maxn];
int find(int x)
{
    if(x!=father[x]) {
        int t = father[x];
        father[x]=find(father[x]);
        value[x] += value[t];
    }
    return father[x];
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int result=0;
        for(int i=0;i<=n;i++)
        {
            value[i]=0;
            father[i]=i;
        }
        int x,y,z;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            x--;
            int aa=find(x);
            int bb=find(y);
            if(aa==bb)
            {
                if(value[x]-value[y]!=z)
                    result++;
            }
            else
            {
                father[aa]=bb;
                value[aa]=value[y]-value[x]+z;
            }
        }
        printf("%d\n",result);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/Vampire6/p/11235421.html
今日推荐