ZOJ——1151 Word Reversal

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1151

题目:

Word Reversal

Time Limit: 2 Seconds       Memory Limit: 65536 KB

For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.


Output

For each test case, print the output on one line.


Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest


Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc


题目描述:

    简单的字符串处理,给出一行单词,把这里面的单词翻转后在输出。单词之间可能不止有一个空格,别问我怎么知道的,,

代码:

#include<stdio.h> 
#include<string.h>
void qe(char *aw)
{
	int i;
	for(i = strlen(aw) - 1;i >=0;i--)
		putchar(aw[i]);
}
int main()
{
	int t,i,j,k;
	int a,b,c;
	while(scanf("%d",&a)!=EOF){
		k = 0;
		while(a--){
			if(k)
				putchar('\n');
			scanf("%d",&b);
			char *f = NULL;
			char we[10010],ww[100];
			gets(we);
			for(i = 0 ;i < b;i ++){
				gets(we);
				for(t = 0,f = we;f[0] != '\0';t ++){
					if(f[0] != ' '){
						sscanf(f,"%s",ww);
						qe(ww);
						f = f + strlen(ww);
					}
					else{
						printf("%c",f[0]);
						f = f + 1;
					}
						
				}
				putchar('\n');
			}
			k++;
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/hunt_er/article/details/79304728
ZOJ