D - D ZOJ - 1151

点击打开链接

For each list of words, output a line with each word reversed without changing the order of the words.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


对于每个单词列表,输出一个每个单词颠倒的行而不改变单词的顺序。



这个问题包含多个测试用例!


多输入的第一行是整数N,然后是空行,后面是N个输入块。 每个输入块都采用问题描述中指定的格式。 输入块之间有空行。


输出格式由N个输出块组成。 输出块之间有空行。

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.


你会得到一些测试用例。 第一行包含一个正整数,表示要遵循的病例数量。 每个案例在包含由一个空格分隔的单词列表的行上给出,每个单词只包含大写和小写字母。

Output

For each test case, print the output on one line.


对于每个测试用例,在一行上打印输出。

Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest


Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc


原创代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int m;
	while(scanf("%d",&m)!=EOF)
	{
		while(m--)
		{
			scanf("\n");
			int n;
			scanf("%d\n",&n);
			for(int i=1;i<=n;i++)
			{
				char s[1000004];
				gets(s);
				int l=strlen(s);
				int e=0,r=0;
				int ant=0;		    
				for(int j=0;j<l;j++)
				{
					ant++;
					if(s[j]==' ')
					{
					    e=j-e;
						if(r==0)
						{
							for(int k=j-1,k1=e;k1;k--,k1--)
						    printf("%c",s[k]);
						    printf(" ");
						    r=1;
						    continue;
						}
						for(int k=j-1,k1=e-1;k1;k--,k1--)
						printf("%c",s[k]);	
						printf(" ");
						e=j;
						ant=0;		
					}	
				}
				if(ant!=0)
				{
					for(int j=l-1;ant>0;ant--,j--)
					printf("%c",s[j]);
					printf("\n");
				 } 		
			}
			if(m)printf("\n"); 
		}
	} 
return 0;
}

借鉴代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d%*c",&n);
		while(n--)
		{
			char str[1000500],s[10000];
			gets(str);
			int len = strlen(str);
			int p = 0;
			for(int i = 0;i < len;i++)
			{
				if(str[i] == ' ')
				{
					for(int j = p-1;j >= 0;j--)
					{
						printf("%c",s[j]);
					}
					printf(" ");
					p = 0;
				}
				else 
				{
					s[p] = str[i];
					p++;
				}
			}
			for(int j = p-1;j >= 0;j--)
			{
				printf("%c",s[j]);
			}
			printf("\n");
		}
		if(t) printf("\n");
	}
return 0;
}















猜你喜欢

转载自blog.csdn.net/d1183/article/details/79636745
d
<d>
d'd