POJ3274 Gold Balanced Lineup【Hash函数】

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16870   Accepted: 4774

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers,   N  and   K.  
Lines 2.. N+1: Line   i+1 contains a single   K-bit integer specifying the features present in cow   i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

Source

扫描二维码关注公众号,回复: 2066603 查看本文章

问题链接POJ3274 Gold Balanced Lineup

问题描述:(略)

问题分析:占个位置,不解释。

程序说明:(略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* POJ3274 Gold Balanced Lineup */

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

using namespace std;

const int MOD = 99991;
const int N = 100000;
const int K = 30;
int sum[N + 1][K];      // 各头牛的属性和
int c[N + 1][K];            // 各头牛与第1头的属性差
int hashv[N * 10];
int n, k;

int hash_key(int cc[])
{
    int key = 0;
    for(int i = 1; i < k; i++)
        key =(key % MOD + cc[i]) << 2;
    key = abs(key) % MOD;
    return key;
}

int main()
{
    int ans = 0;
    memset(sum, 0, sizeof(sum));
    memset(hashv, -1, sizeof(hashv));
    hashv[0] = 0;

    scanf("%d%d",&n,&k);
    for(int i = 1; i <=n; i++) {
        int a;

        scanf("%d", &a);
        for(int j = 0; j < k; j++) {
            sum[i][j] = sum[i - 1][j] + (a & 1);
            c[i][j] = sum[i][j] - sum[i][0];
            a >>= 1;
        }

        int key = hash_key(c[i]);
        while(hashv[key] != -1) {
            int j;
            for(j = 0; j < k; j++)
                if(c[i][j] != c[hashv[key]][j])
                    break;
            if(j == k && ans < (i - hashv[key])) {
                ans = i - hashv[key];
                break;
            }
            key++;
        }
        if(hashv[key] == -1)
            hashv[key] = i;
    }

    printf("%d\n",ans);

    return 0;
}






猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80879473
今日推荐