UVA151 Power Crisis【数学】

During the power crisis in New Zealand this winter (caused by a shortage of rain and hence low levels in the hydro dams), a contingency scheme was developed to turn off the power to areas of the country in a systematic, totally fair, manner. The country was divided up into N regions (Auckland was region number 1, and Wellington number 13). A number, m, would be picked ‘at random’, and the power would first be turned off in region 1 (clearly the fairest starting point) and then in every m’th region after that, wrapping around to 1 after N, and ignoring regions already turned off. For example, if N = 17 and m = 5, power would be turned off to the regions in the order:1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7.

  The problem is that it is clearly fairest to turn off Wellington last (after all, that is where the Electricity headquarters are), so for a given N, the ‘random’ number m needs to be carefully chosen so that region 13 is the last region selected.

  Write a program that will read in the number of regions and then determine the smallest number m that will ensure that Wellington (region 13) can function while the rest of the country is blacked out.

Input

Input will consist of a series of lines, each line containing the number of regions (N) with 13 ≤ N < 100. The file will be terminated by a line consisting of a single ‘0’.

Output

Output will consist of a series of lines, one for each line of the input. Each line will consist of the number m according to the above scheme.

Sample Input

17

0

Sample Output

7


问题链接UVA151 Power Crisis

问题简述

  电厂按照约瑟夫环的规则断电,步长为m,最后停在13号,求m。

问题分析

  这个问题是约瑟夫环问题,用暴力法来解决。在此之前需要做数学的推导,占个位置以后解释。

程序说明:(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:
/* UVA151 Power Crisis */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n;
    while(~scanf("%d", &n) && n) {
        for(int i = 1; i < n; i++) {
            int k = 0;
            for(int j = 1; j < n; j++)
                k = (k + i) % j;
            if(k == 11) {
                printf("%d\n", i);
                break;
            }
        }
    }

    return 0;
}



猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80966581