HDU 5360 Hiking

Hiking

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 431    Accepted Submission(s): 236
Special Judge


Problem Description
There are  n soda conveniently labeled by  1,2,,n. beta, their best friends, wants to invite some soda to go hiking. The  i-th soda will go hiking if the total number of soda that go hiking except him is no less than  li and no larger than  ri. beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than  li and no larger than  ri, otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.
 

Input
There are multiple test cases. The first line of input contains an integer  T, indicating the number of test cases. For each test case:

The first contains an integer  n  (1n105), the number of soda. The second line constains  n integers  l1,l2,,ln. The third line constains  n integers  r1,r2,,rn (0lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.
 

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of  1,2,,n denoting the invitation order. If there are multiple solutions, print any of them.
 

Sample Input
 
    
4 8 4 1 3 2 2 1 0 3 5 3 6 4 2 1 7 6 8 3 3 2 0 5 0 3 6 4 5 2 7 7 6 7 6 8 2 2 3 3 3 0 0 2 7 4 3 6 3 2 2 5 8 5 6 5 3 3 1 2 4 6 7 7 6 5 4 3 5
 

Sample Output
 
    
7 1 7 6 5 2 4 3 8 8 4 6 3 1 2 5 8 7 7 3 6 7 1 5 2 8 4 0 1 2 3 4 5 6 7 8
 

思路:枚举 i , 将所有满足当前i值的所有区间 放入优先队列,从中选择由端点最小的(每次取一个)。在枚举i+1 重复上面的动作。直到队列为空。
其中 为了枚举方便,用vector存储左端点为l[i]的节点。

 
  

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 100000+10
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
struct node{
int l,r,id;
node(int l,int r,int id):l(l),r(r),id(id){};
};
struct cmp{//如过把运算符比较放在结构体里面 会更快些
bool operator()(node a,node b){
if(a.r==b.r)
return a.l>b.l;
return a.r>b.r;
}
};
int vis[maxn],a_id[maxn],l[maxn],r[maxn];
vector<node>v[maxn];
int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt","r",stdin);
#endif
//freopen("out.txt","w",stdout);
int t;
int n;
cin>>t;
while(t--){
cle(vis);
scanf("%d",&n);
for(int i=1;i<=n;i++)scanf("%d",&l[i]);
for(int i=0;i<=n;i++)v[i].clear();
for(int i=1;i<=n;i++)scanf("%d",&r[i]);
for(int i=1;i<=n;i++){
v[l[i]].push_back(node(l[i],r[i],i));
}
priority_queue<node,vector<node>,cmp>q;
int num=0;
for(int i=0;i<=n;i++){//枚举i
if(v[0].size()==0)break;//如果i不为0那么就不会又接下来的事情
for(int j=0;j<v[i].size();j++){
q.push(v[i][j]);
}//将左端点是i的都压入队列
if(q.empty())break;//队列为空 那么就没有满足条件的了
while(!q.empty()){
node x=q.top();
if(x.r>=i) {a_id[num++]=x.id;q.pop();vis[x.id]=1;break;}//找到最小的右端点
else q.pop();
}
}
if(num==0){
printf("%d\n",num);
for(int i=1;i<n;i++)
printf("%d ",i);
printf("%d\n",n);
}
else{
printf("%d\n",num);
printf("%d",a_id[0]);
for(int i=1;i<num;i++)printf(" %d",a_id[i]);
for(int i=1;i<=n;i++)if(!vis[i])printf(" %d",i);
printf("\n");
}
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/u013077144/article/details/51212146
hdu