Hiking——(优先队列priority_queue)

Hiking

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1785    Accepted Submission(s): 910
Special Judge

Problem Description

There are n soda conveniently labeled by 1,2,…,n. beta, their best friends, wants to invite some soda to go hiking. The i-th soda will go hiking if the total number of soda that go hiking except him is no less than li and no larger than ri. beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than li and no larger than ri, otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤105), the number of soda. The second line constains n integers l1,l2,…,ln. The third line constains n integers r1,r2,…,rn. (0≤lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.

Output

For each test case, output the maximum number of soda. Then in the second line output a permutation of 1,2,…,n denoting the invitation order. If there are multiple solutions, print any of them.

Sample Input

4

8

4 1 3 2 2 1 0 3

5 3 6 4 2 1 7 6

8

3 3 2 0 5 0 3 6

4 5 2 7 7 6 7 6

8

2 2 3 3 3 0 0 2

7 4 3 6 3 2 2 5

8

5 6 5 3 3 1 2 4

6 7 7 6 5 4 3 5

Sample Output

 

7

1 7 6 5 2 4 3 8

8

4 6 3 1 2 5 8 7

7

3 6 7 1 5 2 8 4

0

1 2 3 4 5 6 7 8

Author

zimpha@zju

Source

2015 Multi-University Training Contest 6

Recommend

wange2014   |   We have carefully selected several similar problems for you:  6343 6342 6341 6340 6339 

这道题题意就是:

要去邀请hiking的人,但是每一个人都有一个原则,就是当前参加的人要大于等于l[i],小于等于r[i]。(只管当前,之后多少就无所谓了)

然后输出邀请的顺序。(每次邀请的时候都要说一下几个人参加了)

然后这一道题主要应用优先队列,可以把所有的元素用线段表示,然后从0开始每次找左边界l[i]小于等于当前集合人数的元素,然后把它放进集合(或优先队列)中,然后删掉右边界r[i]不符合条件的元素(即右边界小于当前元素,这里不用考虑左边界了,因为在集合中的元素一定是l[i]<=tot才放进来的,只要考虑右边界就行了)。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
struct node{
    int l,r;
    int id;
}a[maxn];
 bool operator <(node a,node b){
    return a.r>b.r;
}
int cmp(node b,node c){
    if(c.l==b.l){
        return b.r<c.r;
    }
    return b.l<c.l;
}

priority_queue<node>q;
node temp;
int c[maxn],vis[maxn];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--){
        while(!q.empty()){
            q.pop();
        }
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i].l);
        }
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i].r);
            a[i].id=i;
        }
        sort(a+1,a+1+n,cmp);
        if(a[1].l>0)
        {
           printf("0\n");
            for(int i=1;i<=n;i++){
                if(i!=n)
                    printf("%d ",i);
                else
                    printf("%d\n",i);
            }
            continue;
        }
        int tot=0;
        int num1=1;

        while(1){
            while(a[num1].l<=tot && num1<=n){
				q.push(a[num1]);num1++;
			}
            while(!q.empty()){
                temp=q.top();
                if(temp.r<tot)
                    q.pop();
                else
                    break;
            }
            if(q.empty()){
                break;
            }
            temp=q.top();
            tot++;
            c[tot]=temp.id;
            vis[temp.id]=1;
            q.pop();
        }

        printf("%d\n",tot);
        for(int i=1;i<=n;i++){
            if(vis[i])
                continue;
            c[++tot]=i;
        }
        for(int i=1;i<=n;i++){
            if(i!=n)
                printf("%d ",c[i]);
            else
                printf("%d\n",c[i]);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/81408864