[kuangbin带你飞]专题一 简单搜索 D - Fliptile

D - Fliptile

 

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M× N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input
Line 1: Two space-separated integers:  M and  N 
Lines 2..  M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white
Output
Lines 1..  M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a[20][20],b[20][20],c[20][20];//原来  改变  答案
int n,m;
int d[5][2]={{0,1},{0,-1},{0,0},{1,0},{-1,0}};
int get(int x,int y)
{
    int r=a[x][y];
    for(int i=0;i<5;i++)
    {
        int xx=x+d[i][0];
        int yy=y+d[i][1];
        if(xx>=1&&xx<=n&&yy>=1&&yy<=m)
        {
            r+=b[xx][yy];
        }
    }
    return r%2;
}
int fliptile()
{
    int sum=0;
    for(int i=2;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            if(get(i-1,j)) b[i][j]=1; //要是上面这个格子上下左右自己之和为奇数就代表需要b[i][j]变
        }
    }
    for(int i=1;i<=m;i++)
    {
        if(get(n,i)) return -1;//要是最后一行有1,代表变得不成功
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            sum+=b[i][j];
        }
    }
    return sum;//要是成功,回复变了几步
}
int main()
{
    cin>>n>>m;
    memset(c,0,sizeof(c));
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            cin>>a[i][j];
        }
    }
    int ans=-1;
    for(int i=0;i<(1<<m);i++)//枚举第一行翻转的各种可能
    {
        memset(b,0,sizeof(b));
        for(int j=1;j<=m;j++)
        {
            b[1][j]=(i>>(j-1))&1;
        }
        int res=fliptile();
        if(res>=0&&(ans<0||res<ans))//不断更新最优解,res<ans,可以保证多个相同步数,保留字典序最小
        {
            ans=res;
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=m;j++)
                {
                    c[i][j]=b[i][j];
                }
            }
        }
    }
    if(ans==-1)
    {
        printf("IMPOSSIBLE\n");
    }
    else
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(j==1) printf("%d",c[i][j]);
                else printf(" %d",c[i][j]);
            }
            cout<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80939756