[kuangbin带你飞]专题一 简单搜索 B - Dungeon Master

POJ - 2251

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

BFS

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

struct node
{
	int x,y,z,k;
};

int l,r,c,xb,yb,zb,f,xe,ye,ze;
char g[50][50][50];
int vis[50][50][50];
int dir[6][3]={1,0,0,-1,0,0,0,0,1,0,0,-1,0,1,0,0,-1,0};
node u,v;

int isok(int z,int x,int y)
{
	if(x<0||y<0||z<0||x>=r||y>=c||z>=l)return 1;
	else if(g[z][x][y]=='#')return 1;
	else if(vis[z][x][y]==1)return 1;
	return 0;
}

int bfs()
{
    u.z=zb;u.x=xb;u.y=yb;u.k=0;
	queue<node>q;
	q.push(u);
	vis[u.z][u.x][u.y]=1;    
	while(!q.empty())
	{
		u=q.front();
		if(u.z==ze&&u.x==xe&&u.y==ye){return u.k;}
		q.pop();
		for(int i=0;i<6;i++)
		{
			v=u;
			v.z=u.z+dir[i][0];
			v.x=u.x+dir[i][1];
			v.y=u.y+dir[i][2];
			if(isok(v.z,v.x,v.y)) continue;
			vis[v.z][v.x][v.y]=1;
			v.k=u.k+1;
			q.push(v);
		}
	}
	return 0;
}

int main()
{
	while(cin>>l>>r>>c)
	{
		if(l==0&&r==0&&c==0)break;
		f=0;
		memset(vis,0,sizeof(vis));
		for(int o=0;o<l;o++)
		    for(int i=0;i<r;i++)
		        for(int j=0;j<c;j++)
		        {
		        	cin>>g[o][i][j];
		        	if(g[o][i][j]=='S'){zb=o;xb=i;yb=j;}
		        	if(g[o][i][j]=='E'){ze=o;xe=i;ye=j;}
				}
        f=bfs();
		if(f)cout<<"Escaped in "<<f<<" minute(s)."<<endl;
		else cout<<"Trapped!"<<endl;
	}
	return 0;
}
扫描二维码关注公众号,回复: 2519344 查看本文章

猜你喜欢

转载自blog.csdn.net/weixin_40829921/article/details/81209658
今日推荐