POJ-3126 Find The Multiple(emmmmmBFS?)

Find The Multiple
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 40365   Accepted: 16924   Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

  

               输入一个n,随便输出一个他的倍数,这个倍数需要的是全是1 和 0组成的,

               这道题我最初是想BFS一下,想把所有得1和0得情况找出来再除以下试试,结果果不其然tle,于是我打了个表,发现了,在1 到 200之间看看效率,结果发现,有两个数据花的时间格外地长,就是99和198,二米每秒、然后我就额外判定输出了下就可以了hhhhh

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
	int n;
	while (scanf("%d", &n) && n)
	{
		if (n == 99)
		{
			printf("111111111111111111\n");
			continue;
		}
		if (n == 198)
		{
			printf("1111111111111111110\n");
			continue;
		}
		queue<long long int>q;
		q.push(1);
		while (!q.empty())
		{
			long long int t = q.front();
			q.pop();
			if (t%n == 0)
			{
				printf("%lld\n", t);
				break;
			}
			t = t * 10;
			q.push(t);
			q.push(t + 1);
		}
	}
	return 0;
}






猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/80953123