POJ. 3349 Snowflake Snow Snowflakes

Snowflake Snow Snowflakes
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 47212   Accepted: 12320

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source

#include<iostream>
#include<fstream>
#include<vector>
using namespace std;
const int N=100010;
int arm[N][6];
const int prime=14997;
vector<int> hash1[prime];
bool cmp(int a,int b)
{
	for(int k=0;k<6;k++)
		if(arm[a][0]==arm[b][k])
		{
			bool flag=false;
			for(int i=0;i<5;i++)
				if(arm[a][1+i]!=arm[b][(k+i+1)%6])
				{
					flag=true;
					break;
				}
			if(!flag)
				return true;
			flag=false;
			for(int i=0;i<5;i++)
				if(arm[a][1+i]!=arm[b][(k-i-1+6)%6])
				{
					flag=true;
					break;
				}
			if(!flag)
				return true;
		}
	return false;
}
bool cmp2(int a, int b){   //  比较两片雪花时候是相同的。
    int i, j;
    for(i = 0; i < 6; i++)
        if(arm[a][0] == arm[b][i]){
            for(j = 1; j < 6; j ++)    //  顺时针方向比较。
                if(arm[a][j] != arm[b][(i+j)%6])  // 除6取模这个方法该学。
                    break;
            if(j == 6) return true;
            for(j = 1; j < 6; j++)     //  逆时针方向比较。
                if(arm[a][6-j] != arm[b][(i+j)%6])
                    break;
            if(j == 6) return true;
        }
    return false;
}
bool check()
{
	for(int k=0;k<prime;k++)
		for(int i=0;i<hash1[k].size();i++)
			for(int j=i+1;j<hash1[k].size();j++)
				if(cmp(hash1[k][i],hash1[k][j]))
					return true;
	return false;
}
int main()
{
	int n;
	cin>>n;
	int sum=0;
	for(int i=0;i<n;i++)
	{
		sum=0;
		for(int j=0;j<6;j++)
		{
			cin>>arm[i][j];
			sum+=arm[i][j];
		}
		hash1[sum%prime].push_back(i);
		
	}
	bool flag=check();
	if(!flag)
		cout<<"No two snowflakes are alike."<<endl;
	else
		cout<<"Twin snowflakes found."<<endl;
	system("pause");
	return 0;
}

题目链接

http://poj.org/problem?id=3349

扫描二维码关注公众号,回复: 1936119 查看本文章


猜你喜欢

转载自blog.csdn.net/yky__xukai/article/details/80167451
今日推荐