Snowflake Snow Snowflakes POJ - 3349 (哈希)

版权声明:转载请标明出处 https://blog.csdn.net/weixin_41190227/article/details/86549472

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

题目大意:给你一个六边形六条边的边长,给出的顺序可能是顺时针的也可能是逆时针的,给出的起点也是不一定的,找是否有两个六边形是一样的。

解题思路:正着分别求出6个数的hash值,反着也求一边,每次都找到最小的那个hash值,存放到vector中,每次都遍历vector判断是否有相同的即可。

要用scanf和printf输入,用C++的cin,cout,关闭输入输出流都没有用。。。只能得到TLE 。

/*
@Author: Top_Spirit
@Language: C++
*/
//#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std ;
typedef unsigned long long  ull ;
typedef long long ll ;
const int Maxn = 1e5 + 10 ;
const int INF = 0x3f3f3f3f ;
const ull seed = 233 ;
const ull MOD = 1e4 + 7 ;

int a[10], b[10] ;
vector < ull > ve[Maxn] ;

int main (){
//    ios_base::sync_with_stdio(false) ;
//    cin.tie(0) ;
//    cout.tie(0) ;
    int n ;
//    cin >> n ;
    scanf("%d", &n) ;
    for (int i = 0; i <= Maxn; i++) ve[i].clear() ;
    int flag = 0 ;
    for (int i = 1; i <= n; i++){
        memset(a, 0, sizeof(a)) ;
        memset(b, 0, sizeof(b)) ;
        ull _Hash = 0 ;
        for (int j = 0; j < 6; j++) scanf("%d", &a[j]) ;
        for (int j = 0; j < 6; j++) b[j] = a[5 - j] ;
        ull Min = -1 ;
//        cout << "+++" << Min << endl ;
        for (int j = 0; j < 6; j++){
            _Hash = 0 ;
            for (int k = j; k < 6; k++) _Hash = _Hash * seed + a[k] ;
            for (int k = 0; k < j; k++) _Hash = _Hash * seed + a[k] ;
            if (Min == -1) Min = _Hash ;
            else Min = min(Min, _Hash) ;
        }
        for (int j = 0; j < 6; j++){
            _Hash = 0 ;
            for (int k = j; k < 6; k++) _Hash = _Hash * seed + b[k] ;
            for (int k = 0; k < j; k++) _Hash = _Hash * seed + b[k] ;
            Min = min (Min, _Hash) ;
        }
        int pos = Min % MOD ;
//        cout << pos << endl ;
//        cout << Min << endl ;
        for (int j = 0; j < ve[pos].size(); j++){
            if (ve[pos][j] == Min){
                flag = 1 ;
                break ;
            }
        }
        if (flag) continue ;
        else ve[pos].push_back(Min) ;
    }
    if (flag) puts("Twin snowflakes found.") ;
    else puts("No two snowflakes are alike.") ;
    return 0 ;
}

猜你喜欢

转载自blog.csdn.net/weixin_41190227/article/details/86549472
今日推荐