POJ Snowflake Snow Snowflakes hash表

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

题意:有n个字符串,每个字符串长度是6,定义二个字符串相同,任意取一个起点,按顺时针或逆时针,取出一段长度为6的字符串 可以得到二个相同的字符串 

解法:这个可以用hash表做,可以知道,二个相同的雪花,他们的和相等,积也相等,可以hash他们的和和积做表头,

当然取模要取一个接近n的,并且小于n的质数 时间复杂度为o(n*n/mod)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<set>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstdlib>
#include<deque>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int>P;
const int len=1e5+5;
const double pi=acos(-1.0);
const ll mod=99991;
const ull seed=131;
int H(int *a)
{
	int sum=0,mul=1;
	for(int i=0;i<6;++i)
	{
		sum=(sum+a[i])%mod;
		mul=(ll)mul*a[i]%mod;
	}
	return (sum+mul)%mod;
}
int head[len],nex[len];
int ver[len][10];
int tot;
int judge(int *a,int *b)
{
	int c[20],d[20];
	for(int i=0;i<6;++i)c[i]=c[i+6]=b[i];
	for(int i=0;i<12;++i)d[i]=c[11-i];
	for(int i=0;i<=5;++i)
	{
		int l=0;
		for(int j=i;j<i+6;++j)
			if(c[j]==a[l])l++;
			else break;
		if(l==6)return 1;	
		l=0;
		for(int j=i;j<i+6;++j)
			if(d[j]==a[l])l++;
			else break;
		if(l==6)return 1;
	}
	return 0;
}
int solve(int *a)
{
	int v=H(a);
	for(int i=head[v];i;i=nex[i])
		if(judge(a,ver[i]))return 1;
	tot++;
	for(int i=0;i<6;++i)ver[tot][i]=a[i];
	nex[tot]=head[v];
	head[v]=tot;
	return 0;
}
int main()
{	
	int n;
	cin>>n; 
	for(int i=0;i<n;++i)
	{
		int a[10];
		for(int j=0;j<6;++j)scanf("%d",&a[j]);
		if(solve(a))
		{
			puts("Twin snowflakes found.");
			return 0;
		}
	}
	puts("No two snowflakes are alike.");
} 




猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/86530758
今日推荐