poj3349 Snowflake Snow Snowflakes(hash)

Snowflake Snow Snowflakes

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.

题意:给定每片雪花6个角的长度,求是否有两片完全相同的雪花。

分析:对每片雪花平方和hash。

代码

#include <cstdio>
#define ll long long
#define N 1000007
using namespace std;

int n;
ll h[N];

int hash(ll x, ll k)
{
    int tmp = x % N;
    while (h[tmp] && h[tmp] != k) tmp = (tmp + 1) % N;
    return tmp;
}

int main()
{
    scanf("%d", &n);
    bool fl = false;
    for (int i = 1; i <= n; i++)
    {
        ll s = 0;
        ll k = 0;
        for (int j = 1; j <= 6; j++)
        {
            ll x;
            scanf("%lld", &x);
            s+=x * x;
            k+=x;
        }
        int val = hash(s, k);
        if (h[val] == k) fl = true;
            else h[val] = k;
    }
    if (fl) printf("Twin snowflakes found.");
        else printf("No two snowflakes are alike.");
}

猜你喜欢

转载自blog.csdn.net/zhanghaoxian1/article/details/81735267
今日推荐