zcmu.oj-1136: 2^x mod n = 1

Description

Give a number n, find the minimum x that satisfies 2^x mod n = 1.

Input

One positive integer on each line, the value of n.

Output

If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input

2
5

Sample Output

2^? mod 2 = 1
2^4 mod 5 = 1

代码:

#include<stdio.h>  
int main()  
{  
    int n;  
    while(scanf("%d",&n)!=EOF)  
    {  
        if(n==1||n%2==0)
        {  
            printf("2^? mod %d = 1\n",n);  
            continue;  
        }  
        int w=2,j=1;  
        while(w!=1)  
        {  
            j++;  
            w*=2;  
            w%=n; 
  
        }  
      printf("2^%d mod %d = 1\n",j,n);  
    }  
    return 0;  
}  

猜你喜欢

转载自blog.csdn.net/kyrieee/article/details/80220350
今日推荐