POJ1696

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/tju_peter/article/details/82190737

Space Ant

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 5247   Accepted: 3271

Description

The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations: 

  1. It can not turn right due to its special body structure. 
  2. It leaves a red path while walking. 
  3. It hates to pass over a previously red colored path, and never does that.


The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes, no two plants share the same x or y
An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance. 
The problem is to find a path for an M11 to let it live longest. 
Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line. 

Input

The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.

Output

Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.

Sample Input

2
10
1 4 5
2 9 8
3 5 9
4 1 7
5 3 2
6 6 3
7 10 10
8 8 1
9 2 4
10 7 6
14
1 6 11
2 11 9
3 8 7
4 12 8
5 9 20
6 3 2
7 1 6
8 2 13
9 15 1
10 14 17
11 13 19
12 5 18
13 7 3
14 10 16

Sample Output

10 8 7 3 4 9 5 6 2 1 10
14 9 10 11 5 12 8 7 6 13 4 14 1 3 2

Source

Tehran 1999

题意大概就是一个虫子只能左转,类似贪吃蛇的样子,不能走自己经过的点,问最长路径

能看出来,肯定存在一条路径走完所有的点。刚开始想用凸包做,想的就是一层一层的求凸包,后来看见和自己做法一样的了,但是刚开始没想明白为什么起点要选y最小的点后来想了一下,发现,如果你不选y最小的点,总有一步会出现右转的情况。

后来看了discuss,每次找到当前的这个点,然后以此为基准极角排序,发现这种做法每次找第一个点就是每次转的角度最小的点,莺哥也是最优的点,而且写起来比较简单。

后来发现一种求凸包的方法,卷包裹法,和这种做法有些类似,就去查了一下,并没有看完,先mark一下~

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<queue>
#include<vector>

using namespace std;

struct point 
{
    double x,y;
    int num;
    point (){};
    point (double _x,double _y){x=_x,y=_y;};
};

point o;
double xmult(point o,point a,point b)
{
    return ((a.x-o.x)*(b.y-o.y)-(b.x-o.x)*(a.y-o.y));
}
double dis(point a,point b)
{
    return (b.x-a.x)*(b.x-a.x)+(b.y-a.y)*(b.y-a.y);
}
bool cmp(point a,point b)
{
    double kk=xmult(o,a,b);
    if(kk!=0) return kk>0;
    else return dis(o,a)<dis(o,b);
    return false;
}
int t,n,asho=0;
point p[55];
point q[55];
int ans[55];
int main()
{
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>p[i].num>>p[i].x>>p[i].y;
        point c(1e9,1e9);
        int cnum=0;
        for(int i=0;i<n;i++)
        {
            if(p[i].y<c.y)
            {
                cnum=i;
                c.y=p[i].y;
                c.x=p[i].x;
            }
            else if(p[i].y==c.y && p[i].x<c.x)
            {
                cnum=i;
                c.y=p[i].y;
                c.x=p[i].x;
            }
        }
        swap(p[0],p[cnum]);
        o=p[0];
        for(int i=1;i<n;i++)
        {
            sort(p+i,p+n,cmp);
            o=p[i];
        }
        cout<<n<<' ';
        for(int i=0;i<n;i++)
        {
            cout<<p[i].num;
            if(i!=n-1) cout<<' ';
        }
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tju_peter/article/details/82190737
POJ