POJ 1029

False coin

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20114 Accepted: 5682

Description

The “Gold Bar”bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: ‘<’, ‘>’, or ‘=’. It represents the result of the weighting:
‘<’ means that the weight of coins in the left pan is less than the weight of coins in the right pan,
‘>’ means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
‘=’ means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

Sample Output

3

Source

Northeastern Europe 1998

题意

​ 给你n个硬币,k组称量结果。在这n个硬币中有一个是假的,他的重量跟其他的不一样(不知道大小),真硬币的重量都相同。每组第一个数字代表左右放置硬币的数量,后面则是硬币的编号,每组后面的符号则是称量结果。问能不能确定哪个是假币,如果不能输出0.

扫描二维码关注公众号,回复: 185337 查看本文章

解题思路

​ 由于数据比较小,所以一开始我就想到了暴力解。如果称量结果是等号,那么两边所有的硬币都是真的。问题剩下,如何在剩下的硬币中找出假的。一开始没什么思路,后来多列了几组数据,就发现了问题。假币出现的次数一定跟非等号数量相等,而且假币一定全部出现在同一边,那么只需要用一个数组记录出现在两边的次数就很容易判断了。如果存在多个硬币出现的次数与非等号相等,且无法直接判断他们的真假,则直接输出0。

代码如下

#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 1005

int weight[maxn],l[maxn],r[maxn],flag[maxn];
int main()
{
//    freopen("in.txt","r",stdin);
    memset(weight,0,sizeof(weight));
    memset(flag,0,sizeof(flag));
    int n,k,ans=0;
    scanf("%d%d",&n,&k);
    for(int i=0; i<k; i++)
    {
        int num;
        scanf("%d",&num);
        for(int j=0; j<num; j++)
            scanf("%d",&l[j]);
        for(int j=0; j<num; j++)
            scanf("%d",&r[j]);
        char t;
        getchar();
        scanf("%c",&t);
        if(t=='=') for(int j=0; j<num; j++)
                flag[l[j]]=flag[r[j]]=1;
        else if(t=='>')
        {
            ans++;
            for(int j=0; j<num; j++)
            {
                weight[l[j]]++;
                weight[r[j]]--;
            }
        }
        else if(t=='<')
        {
            ans++;
            for(int j=0; j<num; j++)
            {
                weight[l[j]]--;
                weight[r[j]]++;
            }
        }
    }
    int sum=0,cur=0;
    for(int i=1; i<=n; i++)
    {
        if(flag[i]) continue;
        if(weight[i]==ans||weight[i]==-ans)
        {
            sum++;
            cur=i;
        }
    }
    if(sum>1) printf("0\n");
    else printf("%d\n",cur);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36258516/article/details/79476740