1029 Median(25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N () is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

思路:

题目要求寻找两个升序序列的中位数,合并寻找会超时,直接开数组会超内存。

你要找的中位数的一定是第(n+m-1)/2,那么维护两个队列,第一队列入队完毕,第二队列每进一个数字就和第一队列的队头比较。小的弹出,并统计弹出的个数cnt++,当cnt==(n+m-1)/2时,检查两个队列队头里最小的那个便是。

注意:在所有元素入队列完毕后,把INT_MAX入队列,一是这样队列永不为空,方便处理。二是,题目的long int因为内存限制原因,并不会为最终答案,只是干扰数据,所以每次遇到这样的干扰数据把他设为INT_MAX即可

C++:

#include <iostream>
#include <climits>
#include <queue>
using namespace std;
int main() {
	queue<int> a, b;
	long long tnum;
	int n, m, num, cnt = 0;
	scanf("%d", &n);
	for(int i = 0; i < n; i++) {
		scanf("%lld", &tnum);
		num = min((long long)INT_MAX, tnum);
		a.push(num);
	}
	a.push(INT_MAX);
	scanf("%d", &m);
	for(int i = 0; i < m; i++) {
		scanf("%lld", &tnum);
		int num = min((long long)INT_MAX, tnum);
		b.push(num);
		if(cnt == (n + m - 1) / 2) {
			printf("%d", min(a.front(), b.front()));
			return 0;
		}
		if(a.front() < b.front())   
			a.pop();
		else                        
			b.pop();
		cnt++;
	}
	b.push(INT_MAX);
	for(; cnt < (n + m - 1) / 2; cnt++) {
		if(a.front() < b.front())    
			a.pop();
		else                         
			b.pop();
	}
	printf("%d", min(a.front(), b.front()));
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ysq96/article/details/80932515