PAT A 1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.
Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.
Output Specification:

For each test case you should output the median of the two given sequences in a line.
Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

坑点是内存问题,我多用一个flag都过不去??参考算法笔记,还是最后一个测试点过不去。

#include<cstdio>

const int INF = 0x7fffffff;
const int maxn = 200010;
int s1[maxn], s2[maxn];
int main() {
    int n1, n2;
    scanf("%d", &n1);
    for (int i = 0; i < n1; i++) {
        scanf("%d", &s1[i]);
    }
    scanf("%d", &n2);
    for (int i = 0; i < n2; i++) {
        scanf("%d", &s2[i]);
    }
    s1[n1] = INF, s2[n2] = INF;//防止越界,将最后一个值设为int最大值
    int i = 0, j = 0, count = 0,mid = (n1 + n2 - 1) / 2;
    while (count<mid) {
        if (s1[i] < s2[j]) i++;
        else j++;
        count++;
    }
    if (s1[i] < s2[j])printf("%d\n", s1[i]);//这里很巧妙,较小的那个就是要输出的值。
    else printf("%d\n", s2[j]);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/81052790