杭电1029

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32767 K (Java/Others)

Problem Description

“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output

3
5
1

思路:

由于共有n个数字,且一定存在出现了(n+1)/2次的数字,所以将所有数字从小到大排序,中间的那个数字【第(n+1)/2个数字】即为所求。

AC代码:

#include <iostream>
#include <algorithm>
using namespace std;
int num[1000000];//一定要写在int main外面
int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
        {
            cin>>num[i];
        }
        sort(num,num+n);
        cout<<num[(n+1)/2]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albert_bolt/article/details/81075620