最短路 (Dijkstra) 算法

最短路算法之二:

Dijkdtra 算法模版:

使用临界矩阵,其时间复杂度O(nlogn):

模版题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1874


Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
 
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
 
  
2 -1


     代码如下(模版):

            

#include <iostream>
using namespace std;
const int maxn  = 210;
const int inf = 0xfffff;

int n, m ,x, y;
int map[maxn][maxn], dis[maxn], vis[maxn];

void Dijkstra (int res) {
    for (int i = 0; i < n; i++){
        dis[i] = map[res][i];
        vis[i] = 0;
    }
    dis[res] = 0;
    vis[res] = 1;
    int temp, k ;
    for (int i = 0; i < n; i++){
        temp = inf;
        for (int j = 0; j < n; j++){
            if (!vis[j] && temp > dis[j]){
                k = j;
                temp = dis[j];
            }
        }
        /*if (temp == inf){
            break;
        }*/
        vis[k] = 1;
        for (int j = 0; j < n; j++){
            if (!vis[j] && dis[j] > dis[k] + map[k][j]){
                dis[j] = dis[k] + map[k][j];
            }
        }
    }
}

int main (){
    while (cin >> n >> m){
        for (int i = 0; i < n; i++){
            for (int j = 0; j < n; j++){
                if (i == j){
                    map[i][j] = 0;
                }
                else{
                    map[i][j] = inf ;
                }
            }
        }
        int a, b, c ;
        for (int i = 0; i < m; i++){
            cin >> a >> b >> c;
            if (map[a][b] > c){
                map[a][b] = map[b][a] = c ;
            }
        }
        cin >> x >> y;
        Dijkstra (x);
        if (dis[y] < inf){
            cout << dis[y] << endl ;
        }
        else{
            cout << -1 << endl;
        }
    }
    return 0;
}
 
 

            还在继续学习其他的算法...  待续......

猜你喜欢

转载自blog.csdn.net/weixin_41190227/article/details/79449243