Relocation(状压DP)

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3
题目大意:
输入n,c1,c2分别代表有n个物品,和两辆最大能承受的重量,求最少能几次运完n个物品。
将一个数的二进制状况表示当前物品的集合,比如10的二进制为1010,即代表第二个和第四个的集合。
枚举所有状态,把能被一次运走的状态记录下来,然后01背包即可。
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
int a[15],dp[1<<10],st[1<<10],vis[1<<10];
int tot,n,c1,c2;
bool check(int s)///检查该状态能不能被一次运完
{
    int sum=0;
    memset(vis,0,sizeof vis);
    vis[0]=1;
    for(int i=0;i<n;i++)
    {
        if((1<<i)&s)
        {
            sum+=a[i];
            for(int j=c1;j>=a[i];j--)
                if(vis[j-a[i]])
                    vis[j]=1;
        }
    }
    if(sum>c1+c2) return 0;
    for(int i=0;i<=c1;i++)
        if(vis[i]&&sum-i<=c2) return 1;
    return 0;
}
int main()
{
    int T,o=0;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,INF,sizeof dp);
        scanf("%d%d%d",&n,&c1,&c2);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        tot=0;
        for(int i=0;i<(1<<n);i++)
            if(check(i))
                st[tot++]=i;
        dp[0]=0;
        for(int i=0;i<tot;i++)///枚举可一次运完状态
            for(int j=(1<<n)-1;j>=0;j--)
                if((j&st[i])==0)///j与st[i]没有交集
                    dp[j|st[i]]=min(dp[j|st[i]],dp[j]+1);
        printf("Scenario #%d:\n%d\n\n",++o,dp[(1<<n)-1]);
    }
    return 0;
}
扫描二维码关注公众号,回复: 1686395 查看本文章
 

猜你喜欢

转载自www.cnblogs.com/zdragon1104/p/9211315.html