HDU - 2444——The Accomodation of Students【二分图】

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8263    Accepted Submission(s): 3649


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
 
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
 
  
No 3
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2438  2443  2442  2441  2440 
 

Statistic |  Submit |  Discuss |  Note

Hangzhou Dianzi University Online Judge 3.0
Copyright © 2005-2018 HDU ACM Team. All Rights Reserved.
Designer & Developer Wang Rongtao LinLe GaoJie GanLu
Total 0.000000(s) query 4, Server time : 2018-06-07 15:06:09, Gzip enabled
先判断是不是二分图,然后在用匈牙利算法求最大匹配。

#include<bits/stdc++.h>
using namespace std;
vector<int> e[100010];
int n,m,vis[100010],match[100010],col[1000010];
int dfs(int u){
    for(int i=0;i<e[u].size();i++){
        int v=e[u][i];
        if(!vis[v]){
            vis[v]=1;
            if(match[v]==0||dfs(match[v])){
                match[v]=u;
                return 1;
            }
        }
    }
    return 0;
}
bool color(int u){
    queue<int> q;
    q.push(u);
    while(!q.empty()){
        int u=q.front();
        q.pop();
        for(int i=0;i<e[u].size();i++){
            int v=e[u][i];
            if(!col[v]){
                col[v]=!col[u];
                q.push(v);
            }
            else if(col[v]==col[u]) return 0;
        }
    }
    return 1;
}
int main(){
    while(~scanf("%d%d",&n,&m)){
        int t1,t2;
        for(int i=1;i<=n;i++) e[i].clear();
        memset(col,0,sizeof(col));
        for(int i=1;i<=m;i++){
            scanf("%d%d",&t1,&t2);
            e[t1].push_back(t2);
            e[t2].push_back(t1);
        }
        bool flag=true;
        col[1]=1;
        if(!color(1)){
            flag=false;
        }
        if(flag){
            memset(match,0,sizeof(match));
            int sum=0;
            for(int i=1;i<=n;i++){
                memset(vis,0,sizeof(vis));
                if(dfs(i)) sum++;
            }
            cout<<sum/2<<endl;//因为邻接矩阵存图的时候正反向都存了,计算了两次
        }
        else{
            cout<<"No"<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/80609685