C/C++[codeup 1929,]今天星期几

1929题目描述:day of week

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入
There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出
Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入
21 December 2012
5 January 2013
样例输出
Friday
Saturday

#include <iostream>
#include <cstring>
using namespace std;
int main() {
    char str[13][10] = {{},
                        {"January"},
                        {"February"},
                        {"March"},
                        {"April"},
                        {"May"},
                        {"June"},
                        {"July"},
                        {"August"},
                        {"September"},
                        {"October"},
                        {"November"},
                        {"December"}
    };
    char str2[7][10] = {{"Monday"},
                        {"Tuesday"},
                        {"Wednesday"},
                        {"Thursday"},
                        {"Friday"},
                        {"Saturday"},
                        {"Sunday"}
    };
    int d, year;
    char month[10];
    while(scanf("%d %s %d",&d,month,&year) != EOF) {
        int i,W = 0;
        for (i = 1; i <= 12; i++)
            if (!strcmp(month, str[i])) break;
        if (i == 1||i == 2) {
            i+=12;
            year--;
        }

        W = d+2*i+3*(i+1)/5+year+year/4-year/100+year/400;
        cout<<str2[W%7]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u014281392/article/details/80672280
今日推荐