HDU-6025-Coprime Sequence(女生赛)

Coprime Sequence

Do you know what is called "Coprime Sequence’’? That is a sequence consists of nn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1."Coprime Sequence’’ is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input

The first line of the input contains an integer T(1≤T≤10),
denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers
a1,a2,…,an (1<=ai<=1e9) denoting the elements in the sequence.

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

Sample Output

1
2
2

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
int const N=1e5+10;
typedef long long ll;
int a[N],b[N],c[N];
int gcd(ll x,ll y)
{
    
    
    return y==0?x:gcd(y,x%y);
}
int main()
{
    
    
  int t;
  scanf("%d",&t);
  while(t--){
    
    
     int n,ans=1;
     scanf("%d",&n);
     memset(a,0,sizeof(a));
     memset(b,0,sizeof(b));
     memset(c,0,sizeof(c));
     for(int i=1;i<=n;i++)
     {
    
    
         scanf("%d",&a[i]);
     }
     sort(a+1,a+1+n);
      b[1]=a[1];
      c[n]=a[n];
      for(int i=2;i<=n;i++)
      {
    
    
          b[i]=gcd(b[i-1],a[i]);//前缀
      }
      for(int i=n-1;i>=1;i--)
      {
    
    
          c[i]=gcd(c[i+1],a[i]);//后缀
      }
      for(int i=1;i<=n;i++)
      {
    
    
          ans=max(ans,gcd(c[i+1],b[i-1]));
      }//每次除去第i个数后的最大公约数
      printf("%d\n",ans);
  }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_52879528/article/details/121033664