coprime sequence(枚举)

coprime sequence


Do you know what is called Coprime Sequence” ? That is a sequence consists of nn positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
“Coprime Sequence” is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.


Input
The first line of the input contains an integer T(1≤T≤10)T(1≤T≤10), denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of nn integers a1,a2,…,an(1≤ai≤109)a1,a2,…,an(1≤ai≤109), denoting the elements in the sequence.


Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.


Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8


Sample Output
1
2
2


题意:随意剔除一个数,使得剔除后整体的最大公约数最大。
思路:当提到在序列里删除一段连续的数时,可以用前缀和+后缀和。


#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const double eps = 1e-6;
const int INF = 2e9;
const LL LNF = 9e18;
const int mod = 1e9+7;
const int maxn = 1e5+10;
int n;
int a[maxn], l[maxn], r[maxn];
int gcd(int a, int b)
{
    return b==0?a:(gcd(b,a%b));
}
void solve()
{
    scanf("%d",&n);
    for(int i = 1; i<=n; i++)
        scanf("%d",&a[i]);

    l[1] = a[1]; r[n] = a[n];
    for(int i = 2; i<=n; i++)
        l[i] = gcd(l[i-1], a[i]);
    for(int i = n-1; i>=1; i--)
        r[i] = gcd(r[i+1], a[i]);

    int ans = 1;
    l[0] = a[2]; r[n+1] = a[n-1];
    for(int i = 1; i<=n; i++)
        ans = max(ans, gcd(l[i-1], r[i+1]) );
    cout<<ans<<endl;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        solve();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/shf1730797676/article/details/81367334