HDU 6025~~ Coprime Sequence

Do you know what is called ``Coprime Sequence''? That is a sequence consists of nnpositive integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input


The first line of the input contains an integer T(1≤T≤10)T(1≤T≤10), denoting the number of test cases. 
In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence. 
Then the following line consists of nn integers a1,a2,...,an(1≤ai≤109)a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.


Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.


Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

Sample Output

1
2
2

题意:

给出一系列数,它们的最大公约数为1 ,现在你需要在这些数中删掉任意一个数使剩下的书的最大公约数最大

思路:

依次遍历每个数,算出这个数左边的一堆数的最大公约数x1,再算出这个数右边的一堆数的最大公约数x2,gcd(x1,x2)即为删去当前数后剩下的数的最大公约数。遍历每个数得到的最大gcd即为所求。


#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int gcd(int a,int b){
	return b?gcd(b,a%b):a;
}
int main()
{
	int t;
	int a[100001];
	int x[100001];
	int y[100001];
	cin>>t;
	while(t--){
		int n;
		cin>>n;
		for(int i=0;i<n;i++) cin>>a[i];
		sort(a,a+n);
		x[0]=a[0];
        for(int i=1; i<n; i++)
            x[i]=gcd(x[i-1],a[i]);   
        y[n-1]=a[n-1];
        for(int i=n-2; i>=0; i--)
            y[i]=gcd(y[i+1],a[i]);   
        int ans=max(y[1],x[n-2]);
        for(int i=1; i<n-1; i++)
            ans=max(ans,gcd(x[i-1],y[i+1]));
        printf("%d\n",ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/gao506440410/article/details/81363729