Cyclic Nacklace

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.
Input The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output For each case, you are required to output the minimum count of pearls added to make a CharmBracelet. Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5


一开始没有理解题意,没有抓住题的关键信息,后来到网上查了一下资料,在结合题目,豁然开朗~

题意:给出一串字符串,在该字符串的两端加上最少的字符(也可以不加)使得新得到的字符串可以由一个循环节至少循环两次。

那么,问题来了,如何使得加入的字符串长度最小呢?

所以就需要求出给出的字符串的最小循环节,只有是最小的循环节,加上的字符串的长度是最小的,才符合题意。

关键是求最小循环节的长度 len = l - next[l];

l 是给出字符串的长度;

现在解释一下这个公式的来源,这里需要借鉴一下,会更好理解:

用三个数组举例一下

ii 1 2 3 4 5 6
SiSi a b c a b c
nextinexti 0 0 0 1 2 3

对于上面这个例子,循环节长度为3。

ii 1 2 3 4 5
SiSi a b c a c
nextinexti 0 0 0 1 0

对于上面这个例子,循环节长度为5。

ii 1 2 3 4 5 6 7 8
SiSi a b c a b c a b
nextinexti 0 0 0 1 2 3 4 5

对于上面这个例子,循环节长度为3。

有没有发现什么规律?

对于这三个例子,循环节长度都是|S|next|S|

用下面这个图片来说明一下:

由next数组的性质,我们可以理解为是一个最小的循环节在不断循环,用数学的知识也可以解释清楚。

就可以知道为什么 最小循环节 len  = l -next[l] 了。


代码:
#include <iostream>#include <cstdio>#include <cstring>#include <algorithm>

using namespace std;

const int M = 100005;
char t[M];
int m;

void Next(int* next,char t[])
{
    int i = 0,j = -1;
    next[0] = -1;
    while(i < m)
    {
        if(j == -1 || t[i] == t[j])
        {
            i++;
            j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}

int main()
{
    int ts,next[M];
    cin>>ts;
    while(ts--)
    {
        scanf("%s",t);
        m = strlen(t);
        Next(next,t);
        int len = m - next[m];

        if(len != m && m%len == 0)
            printf("0\n");
        else
            printf("%d\n",len-next[m]%len);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/tong_zhi/article/details/79935764
今日推荐