C - Cyclic Nacklace

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3

aaa

abca

abcde

Sample Output

0

2

5

题意概括  :

给出一个字符串,求在其尾部需要加几个字符使其构成循环节

解题思路  :

首先,求出所给字符串的next数组,然后判断字符串数组长度与next数组最后一个值的差值与n的关系:是否等于n以及是否为n的约数,如果不是则所需加字符数量为零,如果是所加字符数量为差值减去n与差值的余数。

#include<stdio.h>
#include<string.h>

int next[100010];
char a[100010];

void get_next(char a[])
{
	int i,j,len;
	
	i = 1;
	j = 0;
	len = strlen(a);
	next[0] = 0;
	
	while(i < len)
	{
		if(j == 0&&a[i] != a[j])
		{
			i ++;
		}
		if(j > 0&&a[i] != a[j])
		{
			j = next[j - 1];
		}
		if(a[i] == a[j])
		{
			next[i] = j+1;
			i ++;
			j ++;
		}
	}
}
int main()
{
	int T,n,l,len;
	
	scanf("%d",&T);
	while(T --)
	{
		n = 0;
		memset(next,0,sizeof(next));
		scanf("%s",a);
		n = strlen(a);
		get_next(a);
		l = n - next[n - 1];
		if(l != n&&n%l == 0)
		l = 0;
		else
		l = l - n%l;
		printf("%d\n",l);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81198836