Cyclic Nacklace(KMP循环节)

Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5


分析:题目要求的是给定一个字符串,问我们还需要添加几个字符可以构成一个由n个循环节组成的字符串。

扫描二维码关注公众号,回复: 2373848 查看本文章

可知我们应该先求出字符串的最小循环节的长度。假设字符串的长度为len,那么最小的循环节就是x = len-next[i-1] ;(此处公式中的[i-1]的意义仅参考于下面我的代码中)

如果x == len,说明它本身没有循环节,需要添加的个数是它本身的长度;
如果有len%x == 0,那么这个字符串就是已经是完美的字符串,不用添加任何字符;
否则需要添加的字符数就是x-len%x,相当与需要在最后一个循环节上面添加几个。

#include<stdio.h>
#include<string.h>
char a[100010];
int len,next[100010];
void kmp()
{
	int i = 1, j = 0,x;
	while(i < len)
	{
		if(j == 0 && a[i] != a[j])
		{
			next[i] = 0;
			i ++;
		}
		else if(j > 0 && a[i] != a[j])
			j = next[j-1];
		else
		{
			next[i] = j + 1;
			i ++; j ++;
		}
	}
	x = len - next[i-1];
	if(x == len)
	   	printf("%d\n", len);
	else
	{
	    if(len % x == 0)
	    	printf("0\n");
	    else
	    	printf("%d\n", x-len%x);
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t --)
	{
		scanf("%s",a);
		len = strlen(a);
		kmp();
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/queen00000/article/details/81156147