poj 1064 最小二分法

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00

这道题大体含义是要你在给出的N个数据中(以米为单位,以厘米为精度),寻找最大的单位截取使其能所得的截断个数达到K个

#include <cstdio>
#include <cmath>
using namespace std;
const int M=10005;
const double inf=200005.0;
double L[M];
int n,k;
bool judge(double x)
{
    int num=0;
    for(int i=0;i<n;i++)
      num+=(int)(L[i]/x);
      if(num>=k)
    return 1;
    else
        return 0;
}
void solve()
{
    double left=0,right=inf;
    double mid;
    for(int i=0;i<100;i++) //代替while(r>l) 避免了精度问题
    {                      //1次循环可以把区间缩小一半,100次可以达到10^(-30)的精度
         mid=(left+right)/2;
        if(judge(mid))
            left=mid;//对于double类型就不用+1了。。。
        else
           right=mid;
    }
    printf("%.2f\n",floor(mid*100)/100);//floor()向下舍入为指定小数位数.如:floor(1.45,0)= 1;floor(1.55,0) = 1
                                        
}
int main()
{
    while(scanf("%d%d",&n,&k)!=-1)
    {
        for(int i=0;i<n;i++)
          scanf("%lf",&L[i]);
        solve();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/80495951