[二分-判断解是否可行]POJ - 1064

Cable master
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 59302   Accepted: 12357

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00
题意:

有n条绳子,他们的长度分别为Li.如果从他们中切割出K条长度相同的绳子的话,这K条绳子每条最长能有多长.

题解:

如题进行二分枚举答案.注意到每条长度的上限是1 - 100000米(100千米)!

而答案要求精确的厘米,因为是要求精确到厘米,所以这里就不能浮点的四舍五入,需要将厘米后的直接舍去

由于是精确到厘米,有两种做法,一种转化为厘米后进行整数二分.

另一种直接进行浮点数的二分这里代码实现主要是浮点二分

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1e4+10;
double arr[maxn],inf = 0x3f3f3f3f,eps = 1e-6;
int n,k;
bool check(double mid) {
    int ans = 0;
    for(int i=0;i<n;i++) {
        ans += int(arr[i] / mid);
    }
    return ans >= k;
}
int main()
{
    while(~scanf("%d%d",&n,&k)) {
        double right = 1e6+10,left = 0.0;
        for(int i=0;i<n;i++) scanf("%lf",&arr[i]);
        while(right - left > eps) {
            double mid = (left + right) / 2;
            if(check(mid)) left = mid;
            else right = mid;
        }
        printf("%.2f\n",floor(right*100)/100);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_38013346/article/details/79965936