区间dp---Cutting Sticks

区间dp,顾名思义,就是在区间上进行动态规划。
通常情况下,这类问题在进行一次决策后,决策区间会由一个大区间分成两个小区间,问题也由一个规模较大问题分解成两个规模较小问题。
这样,就可以从长度较小的区间向长度较大的区间进行递推。
先枚举区间的长度(区间较长的问题一定是由小问题得到的)
然后枚举起点,然后终点就是起点加区间长度,就清楚了。

例题一:

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time. It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price. Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made. The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order. An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.
Sample Input
100 3 25 50 75 10 4 4 5 7 8 0
Sample Output
The minimum cutting is 200. The minimum cutting is 22.
这道题堪称一道经典的数位dp了。
代码:
易错点:每一段的长度要从2开始,因为1没法分成两个子区间。

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int len;
    int cut[100];
    int dp[100][100];
    int n;
    while(scanf("%d",&len))
    {
        if(len==0)
            break;
        cin>>n;
    for(int i=1;i<=n;i++){
        scanf("%d",&cut[i]);
    }
    int k;
    cut[0]=0;
    cut[n+1]=len;
    for(int i=2;i<=n+1;i++){
        for(int j=0;j+i<=n+1;j++){
            k=j+i;//终点
            dp[j][k]=0x3f3f3f3f;
            for(int l=j;l<=k;l++){
                dp[j][k]=min(dp[j][l]+dp[l][k]+cut[k]-cut[j],dp[j][k]);
            }
           // cout<<"j:"<<j<<"   k:"<<k<<dp[j][k]<<endl;
        }
    }
    cout<<"The minimum cutting is "<<dp[0][n+1]<<"."<<endl;
    }
    return 0;
}
未完待续。。。


猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/80355961