Dp基础-Divisibility dfs+记忆化

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16
17 + 5 + -21 - 15 = -14
17 + 5 - -21 + 15 = 58
17 + 5 - -21 - 15 = 28
17 - 5 + -21 + 15 = 6
17 - 5 + -21 - 15 = -24
17 - 5 - -21 + 15 = 48
17 - 5 - -21 - 15 = 18
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.
Input
The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value.
Output
Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.
Sample Input
4 7
17 5 -21 15
Sample Output
 
 
Divisible
思路:dfs搜索所有的+ - 放置的位置显然会超时,那么可以采用记忆化搜索保存搜索过的状态以免浪费时间。
dp[i][j]表示搜索到i位置时的和为j,对和%k,k<100。

COde:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
using namespace std;
const int AX = 1e4+66;
const int M = 1e4;
int a[AX];
int dp[AX][105];
int n , k;
int flag;
void dfs( int id , int sum ){
	if( id >= n ) return;
	if( flag ) return;
	if( id == n - 1 && sum % k == 0 ){
		flag = 1;
		return;
	}
	dp[id][sum] = 1;
	int tm_add = ( sum + a[id+1] ) % k ;
	if( !dp[id+1][tm_add] ){
		dfs( id + 1 , tm_add );
	}
	int tm_minus = ( sum - a[id+1] + k ) % k;
	if( !dp[id+1][tm_minus] ){
		dfs( id + 1 , tm_minus );
	}
}
int main(){
	scanf("%d%d",&n,&k);
	memset( dp , 0 ,sizeof(dp) );
	flag = 0;
	int x;
	for( int i = 0 ; i < n ; i++ ){
		scanf("%d",&x);
		if( x < 0 ){
			x =  ( x + k * M ) % k;
		}
		a[i] = x;
	}
	dfs( 0 , a[0] );
	cout << ( flag ? "Divisible" : "Not divisible" ) << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/frankax/article/details/80245330