3-1 得分(Score ACM-ICPC Seoul 2005,UVa1585)

Question

习题3-1 得分(Score ACM-ICPC Seoul 2005,UVa1585)

题目:给出一个由O和X组成的串(长度为1~80),统计得分。
每个O的分数为目前连续出现的O的个数,X的得分为0。
例如:OOXXOXXOOO的得分为1+2+0+0+1+0+0+1+2+3。

Description
There is an objective test result such as OOXXOXXOOO. An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.
Therefore, the score ofOOXXOXXOOO” is 10 which is calculated by `1+2+0+0+1+0+0+1+2+3.
You are to write a program calculating the scores of test results.

Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by O’ and X' and the length of the string is more than 0 and less than 80. There is no spaces between O’ and ` X’.

Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.
The following shows sample input and output for five test cases.

Sample Input
5
OOXXOXXOOO
OOXXOOXXOO
OXOXOXOXOXOXOX
OOOOOOOOOO
OOOOXOOOOXOOOOX

Sample Output
10
9
7
55
30

Think

  简单题。略。

Code

/*
    习题3-1 得分(Score ACM-ICPC Seoul 2005,UVa1585)

    题目:给出一个由O和X组成的串(长度为1~80),统计得分。
        每个O的分数为目前连续出现的O的个数,X的得分为0。
        例如:OOXXOXXOOO的得分为1+2+0+0+1+0+0+1+2+3。
*/
#include<iostream>
#include<string.h>
using namespace std;

const int maxn = 85;
char str[maxn];

int main(){
    int n,sum;
    int prev;//记录前面累加的和
    scanf("%d", &n);
    while(n--){
        scanf("%s", &str);
        sum = prev = 0;//默认累计为0
        for(int i=0,len = strlen(str);i<len;i++){
            if(str[i] == 'O'){
                prev++;
                sum += prev;
            } else {
                prev = 0;
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/johnnyzen/p/9097430.html
今日推荐