☀L2-001 紧急救援 (25分)[PTA][dijstra最短路][带权的最短路径条数]

作为一个城市的应急救援队伍的负责人,你有一张特殊的全国地图。在地图上显示有多个分散的城市和一些连接城市的快速道路。每个城市的救援队数量和每一条连接两个城市的快速道路长度都标在地图上。当其他城市有紧急求助电话给你的时候,你的任务是带领你的救援队尽快赶往事发地,同时,一路上召集尽可能多的救援队。

输入格式:

输入第一行给出4个正整数N、M、S、D,其中N(2≤N≤500)是城市的个数,顺便假设城市的编号为0 ~ (N−1);M是快速道路的条数;S是出发地的城市编号;D是目的地的城市编号。

第二行给出N个正整数,其中第i个数是第i个城市的救援队的数目,数字间以空格分隔。随后的M行中,每行给出一条快速道路的信息,分别是:城市1、城市2、快速道路的长度,中间用空格分开,数字均为整数且不超过500。输入保证救援可行且最优解唯一。

输出格式:

第一行输出最短路径的条数和能够召集的最多的救援队数量。第二行输出从S到D的路径中经过的城市编号。数字间以空格分隔,输出结尾不能有多余空格。

输入样例:

4 5 0 3
20 30 40 10
0 1 1
1 3 2
0 3 3
0 2 2
2 3 2

输出样例:

2 60
0 1 3
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f;
priority_queue<int,vector<int>,greater<int>>q;
 
const int mod=10e9+7;

const int maxn=550;

int n,m,st,nd;
int vis[maxn],G[maxn][maxn],weight[maxn];
int d[maxn],w[maxn],num[maxn],pre[maxn];

void dijstra(int s)
{
    memset(d,INF,sizeof(d));
    memset(num,0,sizeof(num));
    memset(w,0,sizeof(w));
    memset(vis,0,sizeof(vis));
    d[s]=0;
    w[s]=weight[s];
    num[s]=1;
    for(int i=0;i<n;i++)
    {
        int u=-1,minn=INF;
        for(int j=0;j<n;j++)
        {
            if(vis[j]==0&&d[j]<minn)
            {
                u=j;
                minn=d[j];
            }
        }
        if(u==-1)
            return;
        vis[u]=1;
        for(int j=0;j<n;j++)
        {
            if(vis[j]==0&&G[u][j]!=INF)
            {
                if(d[u]+G[u][j]<d[j])
                {
                    d[j]=d[u]+G[u][j];
                    w[j]=w[u]+weight[j];
                    num[j]=num[u];
                    pre[j]=u;
                }
                else if(d[u]+G[u][j]==d[j])
                {
                    if(w[u]+weight[j]>w[j])
                    {
                        w[j]=w[u]+weight[j];
                        pre[j]=u;
                    }
                    num[j]+=num[u];
                }
            }
        }
    }
}
void outpath(int v)
{
    if(v==st)
    {
        cout<<v;
        return;
    }
    outpath(pre[v]);
    cout<<" "<<v;
}

int main()
{
    cin>>n>>m>>st>>nd;
    for(int i=0;i<n;i++)
    {
        cin>>weight[i];
    }
    fill(G[0],G[0]+maxn*maxn,INF);
    for(int i=0;i<m;i++)
    {
        int u,v;
        cin>>u>>v;
        cin>>G[u][v];
        G[v][u]=G[u][v];
    }
    dijstra(st);
    cout<<num[nd]<<" "<<w[nd]<<endl;
    outpath(nd);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43660826/article/details/109991013