洛谷 P1546 最短网络 Agri-Net ( 最小生成树) 题解

题目来源:

https://www.luogu.org/problemnew/show/P1546

题目描述:

题目背景

农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。

题目描述

约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了用最小的消费,他想铺设最短的光纤去连接所有的农场。

你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。每两个农场间的距离不会超过100000

输入输出格式

输入格式:

第一行: 农场的个数,N(3<=N<=100)。

第二行..结尾: 后来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们限制在80个字符,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为不会有线路从第i个农场到它本身。

输出格式:

只有一个输出,其中包含连接到每个农场的光纤的最小长度。

输入输出样例

输入样例#1: 复制

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

输出样例#1: 复制

28

说明

题目翻译来自NOCOW。

USACO Training Section 3.1

解题思路:

      裸的最小生成树,我用kruscal就行了。。。并查集记得初始化

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
int n;
int tu[105][105];
int father[105];
struct newt{
    int from,to,cost;
}edge[10005];
void init()
{
    for(int i=1;i<=n;i++)
    father[i]=i;
}
int fi(int x)
{
    if(x==father[x])return x;
    return father[x]=fi(father[x]);
}
bool same(int x,int y)
{
    if(fi(x)==fi(y))return 1;
    return 0;
}
void Union(int x,int y)
{
    int u=fi(x),v=fi(y);
    if(u==v)return ;
    father[u]=v;
}
bool cmp(newt a,newt b)
{
    return a.cost<b.cost;
}
void dr()
{
    int i=1,j=1;
    cin>>n;
    for(int i=1;i<=n;i++)
    for(int j=1;j<=n;j++)
    cin>>tu[i][j];
}
void sc()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        cout<<tu[i][j]<<" ";
        cout<<endl;
    }
    
}
void kruscal(int t)
{
    int ans=0;
    for(int i=0;i<t;i++)
    {
        if(same(edge[i].from,edge[i].to))continue;
        Union(edge[i].from,edge[i].to);
        ans+=edge[i].cost;
    }
    cout<<ans<<endl;
}
int main()
{
    dr();
    //sc();
    int t=0;
    init();
    for(int i=1;i<=n;i++)
    for(int j=1;j<=n;j++)
    {
        if(i==j)continue;
        edge[t].from=i;
        edge[t].to=j;
        edge[t++].cost=tu[i][j];
    }
    sort(edge,edge+t,cmp);
    kruscal(t);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40400202/article/details/82695641