hdu 1394 Minimum Inversion Number(线段树)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16802    Accepted Submission(s): 10219


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
 
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
 
  
16

solution:

首先我们利用线段树求出当前的逆序数的个数,然后从0~n-1进行模拟,由于含有的数字范围是0~n-1,我们令移完a[i-1]后的逆序数为sum,那么对于a[i],把它放入最后,逆序数变为sum+n-a[i]-a[i]-1

#include<cstdio>
#include<algorithm>
using namespace std;
#define ls t<<1
#define rs (t<<1)|1
const int maxn = 5200;
int a[maxn],fa[maxn];
struct node{
    int l, r,val;
}tree[maxn*4];
void pushup(int t)
{
    tree[t].val =tree[ls].val+tree[rs].val;
}
void build(int l, int r, int t)
{
    tree[t].l = l;
    tree[t].r = r;
    tree[t].val = 0;
    if (l == r)
    {
        fa[l] = t;
        return;
    }
    int mid = (l + r) / 2;
    build(l, mid, ls);
    build(mid + 1, r, rs);
}
void update(int t)
{
    if (t == 1)return;
    t >>= 1;
    pushup(t);
    update(t);
}
int query(int l, int r, int t)
{
    if (tree[t].l >= l&&tree[t].r <= r)
        return tree[t].val;
    int ans = 0;
    int mid = (tree[t].l + tree[t].r) / 2;
    if (l <= mid)ans+=query(l, r, ls);
    if (r > mid)ans+=query(l, r, rs);
    return ans;
}
int main()
{
    int n,x,y;
    while (~scanf("%d",&n))
    {
        build(1, n, 1);
        int sum = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &a[i]);
            int x = a[i] + 1;
            sum += query(x, n, 1);
            tree[fa[x]].val = 1;
            update(fa[x]);
        }
        int ans = sum;
        for (int i = 0; i < n; i++)
        {
            sum += n - a[i] - a[i] - 1;
            ans = min(ans, sum);
        }
        printf("%d\n", ans);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_22522375/article/details/51628308