Minimum Inversion Number (HDU 1394)——树状数组实现

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23323    Accepted Submission(s): 13849


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
 
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
 
  
16
 Answer
#include<iostream>
#include <memory>
using namespace std;
int bit[5050]={0},n,a[5050];
int min(int a,int b)
{
    return a<b?a:b;
}
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int ans=0;
    while(x){
        ans+=bit[x];
        x-=lowbit(x);
    }
    return ans;
}
int add(int x)
{
    while(x<=n){
        bit[x]++;
        x+=lowbit(x);
    }
    return 0;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
	{
        memset(bit,0,sizeof(bit));
        int ans=0;
        for(int i=1;i<=n;i++)
		{
            cin>>a[i];
            a[i]++;//避免为0的数据
            ans+=sum(n)-sum(a[i]);
            add(a[i]);
        }
        int mn=ans;
        mn=min(mn,ans);
        for(int i=1;i<=n;i++)
		{
            ans+=n-a[i]-(a[i]-1);
            mn=min(mn,ans);
        }
        cout<<mn<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36911138/article/details/80946521