hdu1394Minimum Inversion Number 线段树求逆序数

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24032    Accepted Submission(s): 14233

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10 1 3 6 9 0 8 5 7 4 2

Sample Output

16

Author

CHEN, Gaoli

 

O(n log(n))求出整个序列的逆序数,然后在O(1)求出每次移动数字的逆序数(因为是0到n的排列)。

#include<iostream>
#include<cstdio>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

using namespace std; 

const int maxn = 5555;
int sum[maxn<< 2];

void PushUP(int rt){
    sum[rt] = sum[rt << 1] + sum[rt << 1|1];
}
void build(int l,int r,int rt){
    if(l == r){
        sum[rt] = 0;
        return;
    }
    int m = (l + r)/2;
    build(lson);
    build(rson);
    PushUP(rt);
}
void update(int p,int l,int r,int rt){
    if(l == r){
        sum[rt]++;
        return;
    }
    int m = (l + r)/2;
    if(p <= m){
        update(p,lson);
    }
    else{
        update(p,rson);
    }
    PushUP(rt);
    return;
}
int query(int L,int R,int l,int r,int rt){
    if(L <= l&&r<= R){
        return sum[rt];
    }
    int m = (l + r)>>1;
    int ret = 0;
    if(L <= m){
        ret += query(L,R,lson);
    }
    if(R > m){
        ret += query(L,R,rson);
    }
    return ret;
}


int main(){
    int n;
    while(scanf("%d",&n) != EOF){
        build(0,n-1,1);
        int a[5500],sum = 0;
        for(int i = 0;i < n;i++){
            scanf("%d",&a[i]);
            sum += query(a[i],n-1,0,n-1,1);
            update(a[i],0,n-1,1);
        }
        int ret = sum;
        for(int i = 0;i < n;i++){
            sum += n - a[i] - a[i] - 1;
            ret = min(ret,sum);
        }
        printf("%d\n",ret);
    }
    
    
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37136305/article/details/81479693