hdu 1708 Fibonacci String


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3383    Accepted Submission(s): 1169


Problem Description
After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing -- Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For example :
If str[0] = "ab"; str[1] = "bc";
he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?
 

Input
The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.
 

Output
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N". 
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int. 
 

Sample Input
1 ab bc 3
 

Sample Output
a:1 b:3 c:2 d:0 e:0 f:0 g:0 h:0 i:0 j:0 k:0 l:0 m:0 n:0 o:0 p:0 q:0 r:0 s:0 t:0 u:0 v:0 w:0 x:0 y:0 z:0
 

无法模拟,模拟的话字符串太长,存不下,使用数学方法,f(i)各个字母出现的次数 = f(i - 1) 各个字母出现的次数 + f(i - 2)中各个字母出现的次数.
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int N,n;
    int f[50][26];
    cin>>N;
    string s1,s2;
    while (N--)
    {
        memset(f,0,sizeof(f));
        cin>>s1>>s2>>n;
        for (int i=0; i<s1.size(); i++)
        {
            f[0][s1[i]-'a']++;
        }
        for (int i=0;i<s2.size(); i++)
        {
            f[1][s2[i]-'a']++;
        }
       
        for (int i=2; i<=n; i++)
        {
            for (int j=0; j<26; j++)
            {
                f[i][j]=f[i-1][j]+f[i-2][j];
            }
         }
        for (int i=0; i<26; i++)
        {
            cout<<char('a'+i)<<":"<<f[n][i]<<endl;
        }
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/cute/p/12956795.html