Ice_cream's world I HDU - 2120 (并查集)

ice_cream’s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded.
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output

3

题意:

在瞭望塔之间筑墙分隔冰激淋世界,被墙围绕的为一个小的世界,可颁发ACMer一个奖章,墙所围绕的为一个环。

思路:

用并查集求环数,直接看代码!

代码:

#include<stdio.h>
int f[10010],n,m;
void init()
{
    int i;
    for(i=0; i<=n; i++)
        f[i]=i;
}
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        f[v]=getf(f[v]);
        return f[v];
    }
}
int merge(int v,int u)
{
    int t1,t2;
    t1=getf(v);
    t2=getf(u);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 0; 
    }
    return 1;
}
int main()
{

    int i,x,y,s;
    while(~scanf("%d %d",&n,&m))
    {
        init();
        s=0;
        init();
        for(i=1; i<=m; i++)
        {
            scanf("%d %d",&x,&y);
           s=s+merge(x,y);
        }

        printf("%d\n",s);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/Piink/article/details/105350685
今日推荐