POJ - 2492 \ HDU - 1829 A Bug's Life (并查集)

                                        A Bug's Life

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

#include<stdio.h>
#include<string.h>
int f[5010];
int getf(int i)
{
	if(f[i]==i)
		return i;
	else
	{
		f[i]=getf(f[i]);
		return f[i];
	}
}
void merge(int u,int v)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
		f[t2]=t1;
}
int main()
{
	int i,n,m,a,b,flag,t,s;
	scanf("%d",&t);
	s=0;
	while(t--)
	{
		s++;
		scanf("%d%d",&n,&m);
		for(i=0;i<=n*2;i++)
			f[i]=i;
		flag=0;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			if(getf(a)!=getf(b))
			{
				merge(a+n,b);
				merge(a,b+n);
			}
			else
				flag=1;
			
		}
		if(s!=1)
			printf("\n");
		printf("Scenario #%d:\n",s);
		if(flag==1)
			printf("Suspicious bugs found!\n");
		else
			printf("No suspicious bugs found!\n");
		if(t==0)
			printf("\n");
		}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/kongsanjin/article/details/81482577