Ice_cream's world I-并查集

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded. 
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output

3

题意

给出n个瞭望塔和各个塔之间的围墙数m,也给出了m组a,b表示两者间有围墙连接,求哨塔和围墙把土地分割成了几个部分。

题解

用到了并查集,就是看看能形成几个环,形成环的个数就是答案

代码

Select Code

#include<stdio.h>
int f[1001];
int gef(int v)
{
    if(f[v]==v)
        return v;
    else
        f[v]=gef(f[v]);
    return f[v];
}
int mer(int x,int y)
{
    int t1,t2;
    t1=gef(x);
    t2=gef(y);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 0;
    }
    return 1;
}
int main()
{
    int a,b,c,d,i;
    while(~scanf("%d%d",&a,&b))
    {
        int ans=0;
        for(i=0; i<a; i++)
            f[i]=i;
        for(i=0; i<b; i++)
        {
            scanf("%d%d",&c,&d);
            ans=ans+mer(c,d);
        }
        printf("%d\n",ans);
    }
    return 0;
}
发布了30 篇原创文章 · 获赞 1 · 访问量 223

猜你喜欢

转载自blog.csdn.net/weixin_46204099/article/details/105350476
今日推荐