POJ 3631 Cow Relays Floyd+矩阵快速幂

题目描述

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

输入格式

* Line 1: Four space-separated integers: N, T, S, and E
* Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

输出格式

* Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

样例

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9

Sample Output

10

分析

一句话题意:给定一个T(2 <= T <= 100)条边的无向图,求SE恰好经过N(2 <= N <= 1000000)条边的最短路。

这种类型的题之前已经有人分享过了,感觉没什么好说的,就是矩阵快速幂+Floyd

需要注意的就是初始化

代码

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
const int maxn=220;
typedef long long ll;
ll n,t,s,e,cnt;
map<ll,ll> mp;
struct asd{
	ll jz[maxn][maxn];
	asd(){
		for(ll i=0;i<maxn;i++){
			for(ll j=0;j<maxn;j++){
				jz[i][j]=0x3f3f3f3f;
			}
		}
	}
};
asd a1,a2;
asd cheng(asd xx,asd yy){
	asd zz;
	for(ll k=1;k<=cnt;k++){
		for(ll i=1;i<=cnt;i++){
			for(ll j=1;j<=cnt;j++){
				zz.jz[i][j]=min(zz.jz[i][j],xx.jz[i][k]+yy.jz[k][j]);
			}
		}
	}
	return zz;
}
void solve(ll xx){
	a2=a1;
	xx--;
	while(xx){
		if(xx&1) a2=cheng(a1,a2);
		a1=cheng(a1,a1);
		xx>>=1;
	}
}
int main(){
	scanf("%lld%lld%lld%lld",&n,&t,&s,&e);
	for(ll i=1;i<=t;i++){
		ll w,aa,bb;
		scanf("%lld%lld%lld",&w,&aa,&bb);
		if(!mp[aa]) mp[aa]=++cnt;
		if(!mp[bb]) mp[bb]=++cnt;
		a1.jz[mp[aa]][mp[bb]]=w;
		a1.jz[mp[bb]][mp[aa]]=w;
	}
	solve(n);
	printf("%lld\n",a2.jz[mp[s]][mp[e]]);
	return 0;
}

猜你喜欢

转载自www.cnblogs.com/liuchanglc/p/12790620.html