poj 3613Cow Relays(经过n条边的最短路+矩阵快速幂优化)

Description

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi  ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

Input

* Line 1: Four space-separated integers: NTS, and E
* Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

Output

* Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9

Sample Output

10

Source

USACO 2007 November Gold

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define inf 0x3f3f3f3f
#define maxn 300
int map[maxn][maxn],temp[maxn][maxn],ans[maxn][maxn];
int used[10*maxn];
int p[10*maxn];

using namespace std;
void floyd(int a[][maxn],int b[][maxn],int c[][maxn],int cnt)
{
    for(int k=1;k<=cnt;k++)
    for(int i=1;i<=cnt;i++)
    for(int j=1;j<=cnt;j++)
    if(a[i][k]+b[k][j]<c[i][j])
    c[i][j]=a[i][k]+b[k][j];
}
void copy(int n,int a[][maxn],int b[][maxn])
{
    for(int i=0;i<=n;i++)
    for(int j=0;j<=n;j++)
    {a[i][j]=b[i][j];
    b[i][j]=inf;
    }
}
int solve(int s,int t,int n,int cnt)
{
    while(n)
    {
        if(n&1)
        {
            floyd(ans,map,temp,cnt);
            copy(cnt,ans,temp);
        }
        floyd(map,map,temp,cnt);
        copy(cnt,map,temp);
        n>>=1;
    }
    return ans[s][t];
}
int main()
{int n,t,s,e;
memset(used,0,sizeof(used));
scanf("%d%d%d%d",&n,&t,&s,&e);
int u,v,w;
int cnt=0;
for(int i=0;i<=250;i++)
{for(int j=0;j<=250;j++)
{ans[i][j]=temp[i][j]=map[i][j]=inf;}
ans[i][i]=0;
}
for(int i=0;i<t;i++)
{scanf("%d%d%d",&w,&u,&v);
if(!used[u])
{
    used[u]=1;
    p[u]=++cnt;
}
if(!used[v])
{
    used[v]=1;
    p[v]=++cnt;
}

    map[p[u]][p[v]]=map[p[v]][p[u]]=w;
}
printf("%d\n",solve(p[s],p[e],n,cnt));
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/82927590