Balls in the Boxes(CSU) 快速幂

Description

Mr. Mindless has many balls and many boxes,he wants to put all the balls into some of the boxes.Now, he wants to know how many different solutions he can have.
you know,he could put all the balls in one box,and there could be no balls in some of the boxes.Now,he tells you the number of balls and the numbers of boxes, can you to tell him the number of different solutions? Because the number is so large, you can just tell him the solutions mod by a given number C.
Both of boxes and balls are all different.

Input

There are multiple testcases. In each test case, there is one line cantains three integers:the number of boxes ,the number of balls,and the given number C separated by a single space.All the numbers in the input are bigger than 0 and less than 2^63.

Output

 For each testcase,output an integer,denotes the number you will tell Mr. Mindless

Sample Input

3 2 4
4 3 5

Sample Output

1
4

代码:

#include <stdio.h>
#include <math.h>
#define ll long long
ll qpow(ll a,ll b,ll m){  
    ll ans = 1;  
    ll k = a%m;  
    while(b){  
        if(b&1) ans= ans*k%m;  
        k = k*k%m;  
        b >>= 1;  
    }  
    return ans;  
}  
int main() {
	long long a, b, c;
	while(scanf("%lld %lld %lld", &a, &b, &c)!=EOF) {
		printf("%lld\n", qpow(a,b,c));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/adusts/article/details/80456805