Dragon Balls

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1e4+5;
int fath[maxn],num[maxn],mov[maxn];
int find(int x)
{
	if(fath[x]!=x)
	{
		int t=fath[x];
		fath[x]=find(fath[x]);
		mov[x]+=mov[t];
	}
	return fath[x];
}
void oper(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		fath[fx]=fy;
		num[fy]+=num[fx];
		mov[fx]++;
	}
}
int main()
{
	int T;
	cin>>T;
	for(int cas=1;cas<=T;cas++)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		{
			fath[i]=i;
			num[i]=1;
			mov[i]=0;
		}
		printf("Case %d:\n",cas);
		while(m--)
		{
			getchar();
			char c;
			scanf("%c",&c);
			if(c=='T')
			{
				int x,y;
				scanf("%d%d",&x,&y);
				oper(x,y);
			}
			else 
			{
				int i;
				scanf("%d",&i);
				int ans=find(i),cnt=mov[i];
				printf("%d %d %d\n",ans,num[ans],cnt);
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yuebaba/article/details/81706525