hdu 1250 Hat's Fibonacci (Java大数计算)

Description

A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input

Each line will contain an integers. Process to end of file.

Output

For each case, output the result in a line.

Sample Input

100

Sample Output

4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
        Scanner in = new Scanner(System.in);
        BigInteger[] f = new BigInteger[10005];
        f[1] = f[2] = f[3] = f[4] = BigInteger.valueOf(1); //赋值格式
        int i;
        for(i = 5; i <= 10000; i++)
        {
        	f[i] = f[i-1].add(f[i-2]);
        	f[i] = f[i].add(f[i-3]);
        	f[i] = f[i].add(f[i-4]);
        }
        while(in.hasNext())
        {
        	
        	int n = in.nextInt(); //当n超过30时,就需要用大数类
        	
        	System.out.println(f[n]);
        }
	}

}

猜你喜欢

转载自blog.csdn.net/qq_42819248/article/details/83998483